Tempo aproximado para leitura: 00:00:50 min
Ocorrência
Ao informar Item no pedido de venda apresenta a mensagem 7494 - Código do Serviço 0 não cadastrado.
Ambiente
Cross Segmentos - TOTVS Backoffice (Linha Datasul) - Pedidos de Vendas (MPD) - Todas as versões
Causa
A mensagem 7494 ocorre quando a Natureza de Operação que foi informada para o Item está parametrizada como Serviço e está configurada para reter ISS - Imposto sobre Serviços na fonte, mas o Código de Serviço do Item está zerado.
Solução
A configuração da Natureza de Operação é feita no programa CD0606 - Natureza Operação e a busca do Código de Serviço do Item é realizada nos programas CD0147 - Manutenção Itens x Estab Faturamento ou CD0903 - Atualização Itens Faturamento.
Neste caso, se a Natureza de Operação estiver configurada corretamente deve-se verificar se existe Código de Serviço no CD0147 ou no CD0903 e se este Código está devidamente cadastrado no programa FT0308 - Tabela Códigos Serviço.
0 Comentários