Ocorrência
Help A103ProcPC ao realizar Documento de Entrada
Ambiente
Microsiga Protheus – Compras – A partir da versão 12
Causa
- O sistema pode apresentar o alerta quando não identifica o produto da filial consultada;
- Também pode ocorrer quando há alteração de compartilhamento da tabela SB1 e não efetuado ajuste do campo B1_FILIAL do cadastro de sua tabela SB1 TOP de acordo com o compartilhamento que foi alterado.
Solução
1. Exemplo de compartilhamento da SB1 antes da alteração do compartilhamento.
Exemplo do campo B1_FILIAL com conteúdo D MG do cadastro de produto AGULHA02 antes da alteração de compartilhamento
2. Foi realizado a mudança no compartilhamento da tabela SB1
Não foi realizado o ajuste dos registros antigos do campo B1_FILIAL no exemplo do produto AGULHA02 continuou com D MG
Exemplo Pedido de Compra
Tentativa de Vincular o Pedido de Compra no Documento de Entrada.
Ao tentar vincular um Pedido de Compra na Pré-Nota(MATA140) ou Documento de Entrada(MATA103) de um Produto que não foi ajustado o campo B1_FILIAL para o devido compartilhamento será apresentado o Help A103ProcPC
3. Após ajustar o campo B1_FILIAL de acordo com o compartilhamento que foi alterado, o Help não foi apresentado e o pedido foi vinculado ao Documento de entrada.
Observação: Qualquer ajuste ou alteração na base ou compartilhamento deverá ser realizado por um especialista/consultor com conhecimento em base/apsdu e qualquer ajuste realize em ambiente de teste com backup.
Saiba Mais :
0 Comentários