Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha Datasul - TEC - Mensagem column _Field-map in table PUB._File has value exceeding its max length or precision

relogio.png Tempo aproximado para leitura: 00:01:42 min

Ocorrência
Apresenta a mensagem: SQL: Error: Column _Field-map in table PUB._File has value exceeding its max length or precision.

Ambiente
Framework - Framework (Linha Datasul) – Progress OpenEdge – Todas as versões

Causa
Ocorre para campos do tipo Character. O Progress permite a gravação de mais caracteres do que a largura permite em 4GL - Linguagem de Programação de Quarta Geração. Quando a largura máxima de um campo excede o valor da largura do SQL - Structure Query Language, essas consultas SQL não podem ler os dados do campo.

Solução
Procedimento para solução:

1 - Pare o serviço do Tomcat e o banco correspondente;

2 - Efetue um backup do banco;
3 - Acesse o Proenv do Progress e vá até o diretório onde estão os bancos de dados;
4 - Execute o comando dbtool banco;
5 - No menu que se abrirá, escolher as opções: 2, <enter>, 20, all, all, 3. Desta forma, a ferramenta DBTOOL corrigirá a largura dos campos de todas as tabelas deste banco de dados.
6 - Após o procedimento, inicie novamente o Tomcat.

Saiba mais
Consulte os Kbases a seguir para mais informações sobre a mensagem de erro e a ferramenta DBTOOL:
SQL query fails when column value exceeds SQL max length or precision
What is DBTOOL?

Esse artigo foi útil?
Usuários que acharam isso útil: 1 de 1

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _