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Cross Segmento - Backoffice (Linha Protheus) - SIGAEST - MATA280 - Validação do HELP "MA280DTFEC" ao processar o Fechamento de Estoque

Cross Segmento - Backoffice (Linha Protheus) - SIGAEST - MATA280 - Validação do HELP "MA280DTFEC" ao processar o Fechamento de Estoque

time.png Tempo aproximado para leitura: 00:03:00 min

 

Ocorrência

Ao fazer a Virada de Saldos apresenta o HELP MA280DTFEC:

mceclip0.png

 

Ambiente

Protheus – Estoque/Custos – A partir da versão 12.1.17


Causa

Este help está relacionado a alguma data posterior a data de fechamento ou bloqueio, que você está tentando processar. A mensagem é exibida porque o Protheus está tentado realizar a Virada de Saldos com a mesma data que já está gravada nas tabelas SB9, SBJ e SBK e/ou no parâmetro MV_ULMES. 


Solução

1. Verificar o parâmetro MV_ULMES para analisar se é a data que está apresentando no último fechamento do estoque. Verifique também o parâmetro MV_DBLQMOV que frequentemente deve conter a data do último fechamento.

 

2. Verificar em suas tabelas SB9, SBJ e SBK se possui algum registro com data igual ou posterior.

Por exemplo, fazer uma consulta em seu banco de dados conforme o exemplo abaixo:

➣ Tabela SB9  - SELECT MAX(B9_DATA) FROM SB9T10 WHERE D_E_L_E_T_= '
Assim, irá retornar o valor maior do campo B9_DATA que pode coincidir com a data que esteja tentando fazer o fechamento.

 

➣ Tabela SBJ - SELECT MAX(BJ_DATA) FROM SBJT10 WHERE D_E_L_E_T_= '
Retornará o valor maior do campo BJ_DATA que pode coincidir com a data que esteja tentando fazer o fechamento.

 

➣ Tabela SBK - SELECT MAX(BK_DATA) FROM SBKT10 WHERE D_E_L_E_T_= '
Pois irá retornar o valor maior do campo BK_DATA que pode coincidir com a data que esteja tentando fazer o fechamento.

 

3. Caso haja o diagnóstico de que realmente existem registros nas tabelas de Saldos Iniciais com data igual ou posterior à data ao qual está precisando fazer a Virada de Saldos, é recomendável uma análise interna para melhor entendimento (se já houve de fato uma virada de saldos), e se houve, se foi de forma indevida, avaliar a possibilidade de reabertura do período de estoque.

 

Observação importante: o Protheus não dispõe de nenhuma rotina que reabra períodos de estoques da release 12.1.27 e anteriores, sendo um processo específico que a TOTVS recomenda fortemente que seja feito em acompanhamento junto à um analista in loco.

 

4. Caso identificada alguma inconsistência processual ou nos dados durante o fechamento, então é necessário cancelar o fechamento em aberto, inconsistente, e refazer o fechamento do início, evitando o Help MA280DATA.

 

Saiba mais:

SIGAEST - Quais os possíveis impactos da Reabertura de Estoque?

SIGAEST - Erro na chamada do processo em rotinas de Processamento

Clique aqui e veja mais artigos sobre Virada de Saldos no Estoque

 

 

 

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