Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Manufatura - Linha Protheus - APP MNT - Como corrigir a mensagem DBUseArea - DB driver not initialized no app MNTNG

time.png Tempo aproximado para leitura: 00:01:30 min

Ocorrência
Ao realizar processos no MNTNG é apresentada a mensagem DBUseArea - DB driver not initialized.

Ambiente
TOTVS Manufatura - TOTVS Manufatura (Linha Protheus) - Aplicativo MNTNG - Todas as versões

Causa 
Este erro é ocasionado devido a ausência ou configuração incorreta das chaves DBDataBase, DBServer, DBServer, DBPort e DBAlias. Este também ocorre devido a utilização das chaves: TOPDATABASETOPSERVERTOPPORT e TOPALIAS.

Solução
Ao identificar ou mesmo de forma a evitar a mensagem DBUseArea - DB driver not initialized durante a utilização do App MNTNG, deve-se realizar algumas configurações simples no arquivo appserver.ini conforme descrito a seguir:

Na seção Environment a qual esteja vinculado o processo REST definir as chaves:

DBDataBase=<define o tipo do banco de dados utilizado no ambiente, 
podendo ser informado: DB2, INFORMIX, MSSQL, MYSQL, ORACLE e POSTGRES>
DBServer=<endereço ou IP do servidor TOTVS | DBAcess>
DBPort=<porta de acesso TOTVS | DBAcess>
DBAlias=<nome do banco de dados>

Todas as chaves mencionadas devem substituir as respectivas chaves caso estas existam no arquivo de configuração: TOPDATABASETOPSERVERTOPPORT e TOPALIAS. Ao fim o arquivo deve ficar semelhante ao apresentado no exemplo:

[P12127_DDB_REST]
SourcePath=D:\Totvs\Apo\Apo_12127
RootPath=D:\Totvs\Protheus_Data
StartPath=\system_12127_DDB\
RpoDb=SQL
RpoLanguage=Portuguese
RpoVersion=120
LocalFiles=CTREE
localdbextension=.dtc
TopMemoMega=1
DBDataBase=MSSQL7
DBServer=localhost
DBAlias=P12127_DDB_REST
DBPort=12380
HELPSERVER=Localhost:8080
SpecialKey=NGP12127_DDB_HPS
KillStack=1
StartSysInDb=1
Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _