FAQs - Suporte técnico

RH - Linha Protheus - PON - Ao tentar gerar relatórios ocorre erro de função: InterFunctionCall: cannot find function PONX1VALID in AppMap


Ocorrência

No módulo Ponto Eletrônico, ao tentar emitir algum relatório ocorre o erro: InterFunctionCall: cannot find function PONX1VALID in AppMap

Ambiente
TOTVS RH - TOTVS RH (Linha Protheus) - Ponto Eletrônico - Todas as versões

Causa
Este erro ocorre devido a utilização de fontes disponibilizados para outros países e não para o Brasil

Solução
Para solucionar essa ocorrência, realize os seguintes passos:

1. Baixe os RDMAKEs contidos no Pacote Acumulado do link abaixo, conforme a sua versão;

12.1.23 - https://suporte.totvs.com/portal/p/10098/download#detail/750469
12.1.25 - https://suporte.totvs.com/portal/p/10098/download#detail/779794
12.1.27 - https://suporte.totvs.com/portal/p/10098/download#detail/954151

2. Compile os RDMakes padrão do Ponto em seu ambiente.

Se apenas com este processo não funcionar, pode ser que tenha outros fontes no sistema que foram aplicados de pacotes também de outros países, contendo a mesma função PONX1VALID, assim, como não há uma forma de saber quais são pontualmente para atualização, é necessário que baixe o RPO (Brasil) do Portal do cliente, e atualize o mesmo com os pacotes acumulados liberados no portal também do brasil para correção, ou, aplique o pacote acumulado de RH disponibilizado semanalmente, aceitando todos os fontes para atualização, não somente os mais atualizados. No VS CODE, quando aplicar o acumulados, neste caso, selecione a opção Apply Old Files

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _