Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

GoodData - Fast Analytics - Como solucionar o erro Unauthorized no componente FILE_DOWNLOAD

Ocorrência
Ao executar o graph no CloudConnect, o mesmo está retornando o erro "Component [File Download:FILE_DOWNLOAD] finished with status ERROR." Unauthorized Unexpected response.

Ambiente
GoodData – Fast Analytics – Todas as versões.

Causa
Credendiais de acesso ao GoodData não inseridas no arquivo workspace.prm.

Solução

O componente FILE_DOWNLOAD precisa das credenciais de acesso ao GoodData para conseguir acessar o FTP do projeto e baixar os arquivos.

Dessa forma, para solucionar essa ocorrência, realize os seguintes passos:


1. Abra o arquivo workspace.prm, presente na estrutura de arquivos do seu projeto CloudConnect;

2. No parâmetro USER_PWD_SECURE_DI, insira seu usuário e senha no formato: seuemail%40seudominio.com.br:suasenha

3. Salve o arquivo workspace.prm;

4. Execute o graph novamente.

 

Importante:

No formato descrito no item 2, o caractere @ foi substituído por %40, seu equivalente hexadecimal. Caso a senha de acesso tenha caracteres especiais, será necessário substituí-los por seus equivalentes. Segue abaixo alguns exemplos de caracteres especiais e seus respectivos hexadecimais.

 

Caractere: "." - Equivalente: %2e

Caractere: "*" - Equivalente: %2a

Caractere: "@" - Equivalente: %40

Caractere: "#" - Equivalente: %23

Caractere: "!" - Equivalente: %21

Caractere: "$" - Equivalente: %24

 

Caso o mesmo erro esteja ocorrendo ao executar o Agent verifique se dentro do arquivo .properties o parâmetro USER_PWD_SECURE_DI está preenchido da mesma maneira que instruído nesse artigo.

Esse artigo foi útil?
Usuários que acharam isso útil: 1 de 1

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _