FAQs - Suporte técnico

MP - GPE - Error log na troca de turno ou geração de carga com Integração ao TSA (PONM430) - Chave Duplicada na Tabela SYNC_PROTHEUS_TSA


Ocorrência

Ao realizar a troca de turno para um Funcionário, através da rotina PONA160, e/ou executar integração TSA, através da rotina PONM430, é gerado error log: "[SQL Server]Cannot insert duplicate key row in object 'dbo.SYNC_PROTHEUS_TSA' with unique index" ou "ORA-00001: unique constraint (SIGA.SYNC_PROTHEUS_TSA_UNQ) violated".



Ambiente
Microsiga Protheus - Gestão de Pessoal - à partir da versão 12.1.17



Causa 
Este erro ocorre devido aos serviços do Suricato estiverem inativos ou com problemas nas configurações



Solução
1.
Devido a tabela SYNC_PROTHEUS_TSA estar ligada no controle das transações de integrações PROTHEUS X SURICATO, para solucionar este problema deverá entrar em contato com a equipe responsável pelo Suricato para verificar as configurações dos serviços de integração e se os serviços estão ativos e funcionando corretamente.



Saiba mais:
Integração Protheus x Suricato: https://tdn.totvs.com/pages/releaseview.action?pageId=546695095#Integra%C3%A7%C3%A3oProtheusxSuricato

Pacote acumulado RH: https://centraldeatendimento.totvs.com/hc/pt-br/articles/115015741848

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _