Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - Linha Protheus - GPE - Geração de títulos com cadastro automático de fornecedor não cria o fornecedor corretamente

time.pngTempo aproximado para leitura: 00:02:00 min

 

Ocorrência
Geração de títulos com cadastro automático de fornecedor não cria o fornecedor corretamente.

Ambiente
TOTVS RH - TOTVS RH (Linha Protheus) - Gestão de Pessoal – A partir da versão 12.1.17.

Causas
1) Configuração incorreta;
2) Ausência de amarração entre Participantes x Fornecedor;
3) Não foram criados automaticamente os relacionamentos da tabela RD0 e RDZ, no momento do  cadastro de funcionário. 

Solução
Para solucionar cada uma das ocorrências, realize os seguintes passos:

1. Confira a documentação, se a configuração foi realizada corretamente:
MP - GPE - Cadastro Automático de Fornecedores com as informações de Funcionários
 
2. Caso o fornecedor já esteja cadastrado, verifique as amarrações entre Participantes x Fornecedor: 
MP - GPE - Geração de títulos não grava fornecedor já cadastrado no financeiro, gerando um novo fornecedor

3. Crie relacionamento entre o cadastro de funcionário x participantes.

-> Confira se os funcionários possuem CPF em seu cadastro, apenas os registros com CPF serão carregados na rotina de participantes;

-> Extraia/substitua o arquivo MSRELRDZ dentro da sua pasta System (anexo);

-> Certifique-se que o ambiente esta atualizado conforme portal, com Pacote Acumulado, Lib e Binário, e realize um backup das tabelas RD0 e RDZ.

-> Acesse o Modulo 53 em Atualizações -> Participantes -> Cadastros -> Outras ações -> Relacionar. Selecione Relacionar e deixe a rotina processar. Dependendo da quantidade de registros em sua SRA poderá demorar um pouco o processamento. Realize este processo de forma exclusiva, sem usuário utilizando qualquer rotina que possa envolver a tabela SRA (cadastro de funcionário).

O sistema irá considerar todos os registros em sua SRA e relacionar nas tabelas RD0 e RDZ. 

Informações adicionais:

Diferença entre relacionar e atualizar:

Relacionar
Esta opção permite relacionar os dados do Cadastro de Funcionários (tabela SRA) com os dados do Cadastro de Pessoas/Participantes (tabela RD0). Este relacionamento é feito pelo número do CPF do Participante/Funcionário e atualiza a tabela (tabela RDZ) Pessoas x Entidades.

Ao selecionar esta opção é apresentada a mensagem de confirmação Relacionar funcionários inativos?. Quando informar Sim, os funcionários demitidos são importados do Cadastro de Pessoas com o Status Ativo.

Atualizar
Esta opção permite apenas a atualização dos dados cadastrais do colaborador, por exemplo quando há uma alteração de Status, para Demitido. 

 

 

 

Saiba Mais
Artigos sobre Integração de Título

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _