Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - Linha Protheus - GPE - Error log ao alterar Cadastro de Período - type mismatch on compare on GPEA400AMBPREP


Ocorrência

Ao realizar a alterações no Cadastro de Período, através da rotina GPEA400, é gerado error log: type mismatch on compare  on GPEA400AMBPREP(GPEA400.PRW)

Ambiente
TOTVS RH - OTVS RH (Linha Protheus) - Gestão de Pessoal - todas as versões

Causa 
Este erro ocorre devido à inconsistência no parâmetro MV_DIASPER

Solução
Para solucionar esta ocorrência realize o processo conforme descrito abaixo:

1. Acesse o Programa Configurador(SIGACFG) e clique em OK:


2. Acesse a rotina de Base de Dados/Dicionário/Base de Dados;


3. Acesse o caminho Abrir a Empresa e selecione em Parâmetros:


4. Clique em Parâmetros e opte pela Lupa, conforme abaixo: 


Pesquise na seção 'Procurar por:' informando o parâmetro MV_DIASPER e depois clicar em 'Buscar' conforme abaixo:


Após 'Buscar' o parâmetro clique na opção da 'Lupa com uma folha(Visualizar)', conforme abaixo:


5. Após filtrar o parâmetro verifique se o mesmo se encontra conforme demonstrado no print abaixo:
O tipo deve constar como 2-Caractere e o conteúdo deve ser 1 ou 2 de acordo com a necessidade, sendo:
1=Se o divisor será a quantidade de dias do mês do período;
2=Se o divisor será sempre 30;

Exemplo de configuração padrão:


3. Após ajuste o ambiente não apresentará mais o erro ao alterar o período;

Saiba mais:
Pacote Acumulado de RH

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _