Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - Linha Datasul - Meu RH - Tipo de acesso no FP9100 bloqueia acesso a outros programas do Datasul

time.png Tempo aproximado para leitura: 00:02:00 min

Ocorrência

No programa SEC000AA, pasta Geral, botão Compl RH, na tela FP9100, após alterar o tipo de acesso de um usuário de Estabelecimento para Time de Trabalho, Colaborador e etc., o usuário perde as permissões de acesso para programas de outros produtos do ERP como o QO0310 do módulo Datasul Vendas.

Ambiente
TOTVS RH - TOTVS RH (Linha Datasul) - Meu RH - Versão 12

Causa
O problema ocorre devido a regra de arquitetura da função de login unificado no Sistema Datasul, ativada pelo parâmetro Login Unificado/Perfil Acesso no programa FP0540, pasta Visão Usuário.
Com este parâmetro ativo, não pode existir nenhum grupo de segurança em comum entre todos os produtos no Sistema Datasul 12

Solução
É normal que o grupo sup criado no programa BAS_GRP_USUAR seja o grupo que irá fornecer a permissão para todos os programas do ERP Datasul para um usuário de TI ou Administrador, no entanto, com o login unificado ativado em um ambiente que utiliza diversos produtos, será necessário:

1. Desvincular todos os usuários do grupo sup. Individualmente pelo programa BAS_GRP_USUAR ou em lote pelo programa MEN704ZA;
2. Criar um grupo sup para cada produto. Exemplo - se no ambiente são utilizados os produtos HCM e EMS, criar os grupos suphcm e supems;
3. Vincular os novos grupos gerados, no caso do exemplo os grupos suphcm e supems nos respectivos programas dos produtos HCM e EMS, via BAS_PROG_DTSUL.

Será necessário realizar o mesmo processo de forma análoga para todos os grupos de segurança que são compartilhados entre dois ou mais produtos no Datasul 12.

Glossário
SEC000AA - Manutenção Usuário
FP9100 - Usuários
ERP - Enterprise Resource Planning
QO0310 - Manutenção Cotações
FP0540 - Consulta Descentralização RH
BAS_GRP_USUAR - Manutenção de Grupo de Segurança
TI - Tecnologia da Informação
MEN704ZA - Atualização Segurança Menu
BAS_PROG_DTSUL - Manutenção de Programa

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _