Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

TOTVS Educacional - Educacional - EDU - Houve um erro durante a exclusão da entidade Matriz Curricular

Ocorrência
Ao realizar a exclusão de uma Matriz Curricular é apresentado o erro:
Houve um erro durante a exclusão da entidade Matriz Curricular
Violação de chave estrangeira

Possíveis causas:
  - exclusão de registro que possui outros registros associados
  - inclusão de registro detalhe sem um registro mestre associado

The DELETE statement conflicted with the SAME TABLE REFERENCE constraint "FKSGRADEPROX_SGRADE". The conflict occurred in database "Corpore_Producao", table "dbo.SGRADE".
The statement has been terminated.

Ambiente
TOTVS Educacional - Educacional (Linha RM) - EDU -Todas as versões

Causa
O erro ocorre pois a grade está amarrada ao cadastro da próxima grade em outra Matriz Curricular.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:

Acesse a Matriz Curricular anterior e retire a informação preenchida no cadastro Próximo Curso:

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _