Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

MP - SIGAFRT - Erro ao estabelecer a conexão: variable is not an object

Ocorrência
No módulo TOTVS PDV, ao tentar realizar o cadastro de HOST, mensagem é apresentada:

mceclip0.png

 

Ambiente
Microsiga Protheus – SIGAFRT/TOTVS PDV – A partir da versão 12.1.17

Causa
Esse incidente ocorre, quanto HOST cadastrado em retaguarda, não é identificado por TOTVS PDV.

Solução
Realize a configuração de HOST em ambiente Retaguarda, apontando porta de SmartClient para o mesmo appserver.ini que contem o JOB WS.

Exemplo de cenário:

MASTER WS Balance
Job Gravabatch WebService Slave1
TCP 1234 TCP 1246 TCP 1256

Neste cenário o HOST deve ser configurado em Slave WS (TCP 1246).

MASTER Balance
Job Gravabatch Slave1
WebService  
TCP 1234 TCP 1256

Neste cenário o HOST deve ser configurado em Slave MASTER (TCP 1234)

Saiba Mais:
MP - TOTVS PDV - Configuração de comunicação TOTVS PDV
MP - Desvendando Carga de Ambiente

 

 

 

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _