Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

MP-CRM-InterFunctionCall: cannot find function FT320STAT

Ocorrência
Erro ao gerar uma oportunidade de vendas:

InterFunctionCall: cannot find function FT320STAT in AppMap on {|a,b,c| FWInitCpo(a,b,c),lRet:=(Ft320Stat()),FWCloseCpo(a,b,c,lRet,.T.),lRet }(PROTHEUSFUNCTIONMVC.PRX) 01/04/2020 19:16:48 line : 5471

Ambiente

Microsiga Protheus - a partir da versão 12.

Causa

O erro ocorre por que o  x3_relação (inicializador padrão),x3_inibrw( inicializador de browser),x3_when(modo de edição), x3_valid(Validação do sistema) ou x3_vlduser (validação de usuário) do campo AD1_STATUS está chamando a função FT320STAT que encontra-se descontinuada.

Solução

Para solucionar essa ocorrência, reavalie as validações do campo AD1_STATUS deixando conforme o padrão do sistema:

Inicializador padrão: "1": 

Inic.Browse: Vazio

Modo de Edição: !Empty(FwFldGet("AD1_FCI")) .OR. !Empty(FwFldGet("AD1_FCS"))

Validação de Usuário: Vazio

Validação do Sistema: Ft300VdVis() .AND. Ft300VProp() .AND. Ft300VldFC() .AND. Ft300OpEnc()  

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _