Tempo aproximado para leitura: 00:01:30 min
Ocorrência
Ao realizar alteração da data de pagamento de qualquer roteiro de cálculo na rotina de períodos gera a mensagem: Cálculo já efetuado para este roteiro!
Ambiente
TOTVS RH - TOTVS RH (Linha Protheus) - Gestão de Pessoal - A partir da versão 12.1.17
Causa
A mensagem ocorre pois existe cálculo já efetuado para o roteiro.
Solução
Ao realizar alteração da data de pagamento de qualquer roteiro de cálculo gera a mensagem: Cálculo já efetuado para este roteiro! Para evitar inconsistência na geração do evento S1210 do eEsocial, realize o cancelamento para alteração da data de Pagamento.
Essa mensagem foi incluída pela pagadoria no fonte GPEA400 em 03/12/19. Ela foi inserida porque quando é feito alteração da data de pagamento, a informação do cadastro de períodos fica divergente do campo de pagamento da SRD e SRC. E o sistema verifica as informações para gerar o S-1210.
Nesse caso se um cálculo é realizado com data X, e é feito a alteração da data em períodos, ao fechar a folha temos uma data de cálculo no cadastro de períodos e outra no movimento fechado do trabalhador.
O fato de alterar a data de pagamento no cadastro de período com um cálculo já realizado, não é um problema apenas no eSocial, isso também é um erro de processo do usuário na folha. Se o sistema permitir fazer isso, a título de auditoria o que foi cadastrado em períodos não bate com o que foi calculado, a data de pagamento no cadastro de períodos não é um campo para ser utilizado por trabalhador, mas sim por roteiro.
Caso haja a necessidade de alteração da data do roteiro, será necessário efetuar o cancelamento do cálculo do roteiro a ser alterado, cancelando todos os tipos de cancelamento e deixando o campo Data de referencia De e Data de Referencia Até em branco.
Segue exemplo de preenchimento do parâmetro:
Selecione o Tipo de Cancelamento, lembrando que a rotina só permite efetuar um tipo de cancelamento por vez, pois não existe a opção de selecionar todos os tipos.
0 Comentários