Tempo aproximado para leitura: 00:01:30 min
Ocorrência
Ao realizar alteração da data de pagamento de qualquer roteiro de cálculo na rotina de períodos gera a mensagem: Cálculo já efetuado para este roteiro!
Ambiente
TOTVS RH - TOTVS RH (Linha Protheus) - Gestão de Pessoal - A partir da versão 12.1.17
Causa
A mensagem ocorre pois existe cálculo já efetuado para o roteiro.
Solução
Ao realizar alteração da data de pagamento de qualquer roteiro de cálculo gera a mensagem: Cálculo já efetuado para este roteiro! Para evitar inconsistência na geração do evento S1210 do eEsocial, realize o cancelamento para alteração da data de Pagamento.
A mensagem foi incluída porque, ao alterar a data de pagamento no cadastro de períodos após o cálculo já ter sido realizado, ocorre divergência entre essa data e a registrada nos movimentos (SRD/SRC). Essa diferença compromete a integridade das informações e impacta diretamente na geração do S-1210.
Alterar a data de pagamento após o cálculo é considerado um erro de processo, pois o campo é destinado ao roteiro e não ao controle individual por trabalhador.
Caso seja necessário alterar a data do roteiro, será preciso cancelar todos os tipos de cálculo já realizados para esse roteiro. Após o cancelamento, os campos Data de Referência De e Data de Referência Até devem ser deixados em branco.
-> Segue exemplo de preenchimento dos parâmetros:
-> Selecione o Tipo de Cancelamento, lembrando que a rotina só permite efetuar um tipo de cancelamento por vez, pois não existe a opção de selecionar todos os tipos.
Saiba Mais:
RH - Linha Protheus - GPE - Como efetuar o cadastro de período
RH - Linha Protheus - GPE - Como Criar Períodos Automaticamente pela Rotina Geração Período Padrão
RH - Linha Protheus - GPE - Como criar processo e período de cálculo diferente do padrão já existente no sistema
RH - Linha Protheus - GPE - Tabelas utilizadas para o Cadastro de Período GPEA400
0 Comentários