Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

MP - TOTVS PDV - Mensagem de inconsistência na tabela SLX ao cancelar uma venda

Ocorrência
No TOTVS PDV, ao realizar o cancelamento de uma venda efetuada, após seu processamento, é apresentado a mensagem de inconsistência na tabela SLX:
"SLX990: SQLite Error (19) UNIQUE constraint failed: SLX990.LX_FILIAL, SLX990.LX_PDV, SLX990.LX_CUPOM, SLX990.LX_SERIE, SLX990.LX_ITEM, SLX990.LX_HORA, SLX990.R_E_C_D_E_L_ on MSUNLOCK(APLIB060.PRW)"

Ambiente
Microsiga Protheus – TOTVS PDV – A partir da versão 12.1.17

Causa
Patch de correção não aplicado.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Aplique o pacote de correção abaixo em ambiente conforme release.

DVARLOJ4-8206
12.1.27:https://r.totvs.io/p/975391 ;
12.1.25:
https://r.totvs.io/p/975390 ;
12.1.23:
https://r.totvs.io/p/975389 ;
12.1.17:
https://r.totvs.io/p/975388 ;


Importante
Para release 12.1.17, o patch somente pode ser aplicado se possuir Garantia Estendida da release, caso contrário, comprometerá a funcionalidade do ambiente.


Saiba Mais
Para mais informações, acesse: DVARLOJ4-8206 DT Mensagem de inconsistência apresentada no cancelamento TOTVS PDV

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _