Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - Linha Protheus - GPE - Validação de títulos gerados com o cálculo da Rescisão

time.png Tempo aproximado para leitura: 00:02:00 min

 

Ocorrência
Validação de títulos gerados com o cálculo da Rescisão.

Ambiente
TOTVS RH - TOTVS RH (Linha Protheus) - Gestão de Pessoal - A partir da versão 12

Causa
Implementação de tratamento para validação de exclusão de rescisões que já tenham títulos gerados/integrados com o financeiro.
Sistema precisa emitir mensagem informando que já existem títulos gerados/integrados para a rescisão em questão, alertando o usuário para necessidade de efetuar a manutenção desses títulos antes de realizar nova integração.

Solução

Efetuada a criação da Tabela RJ1 para que sejam gravadas as rescisões referentes ao título. Criado mecanismo para verificar durante a exclusão ou recálculo da rescisão se existe algum registro da rescisão na tabela RJ1. Caso exista, será exibido o alerta abaixo, dando ao usuário possibilidade de prosseguir ou não com a operação: 

 



Detalhes da tabela RJ1 (releases anteriores ao 12.1.25 necessária a criação via Configurador - lembrando que campos criados dessa maneira ficam marcados como campos de usuário e suas respectivas manutenções via UPDDISTR, caso necessárias, serão limitadas): 

mceclip0.png

Importante
O tamanho do campo RJ1_NUMTIT deve ser igual ao do campo RC1_NUMTIT para que a implementação funcione corretamente.

 


Saiba Mais
Artigos sobre Integração de Títulos

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _