Ocorrência
O Disparo de Workflow da empresa está abrindo um processo de envio para cada conta de e-mail da lista de contatos. Tal ação está demandando muitas horas de processamento.
Como proceder para que o envio se torne único para todos os e-mails listados?
Ambiente
Cross Segmento - TOTVS Backoffice Linha Protheus – Workflow – A partir da versão 12.1.17
Causa
A lentidão ocorre pois a forma de envio dos e-mails do Workflow está configurada como "Individualmente" dentro Configurador do Protheus. Desta forma, é criado um processo por vez de disparo para cada conta dentro da lista.
Solução
Neste caso, quando existe uma lista de e-mails para disparo, o ideal é alterar a forma de envio para "Em Lote" dentro do Configurador do Protheus, criando apenas um processo que enviará o mesmo e-mail para todas as contas cadastradas da lista.
Para alterar esta configuração, acesse o Configurador e dentro da Aba "Workflow", escolha a opção "Parâmetros de Workflow".
Será apresentado as duas opções de envio: 1-Em Lote ou 2-Individualmente.


0 Comentários