Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - Linha Protheus - GPE - FWNOWIDTH valor atribuído difere do tamanho do campo (Desc.Funçao)

time.png Tempo aproximado para leitura: 00:02:00 min

Ocorrência

Em Gestão de Pessoas ao incluir uma convocação, no campo função aparece o erro abaixo:

mceclip0.png

Ambiente

TOTVS RH - TOTVS RH (Linha Protheus) - Gestão de Pessoal - A partir da versão 12.1.17

Causa

O erro ocorre quando os campos V7_DFUNC, RJ_DESC tem tamanho de campo diferente de 20, não sendo permitido  realizar alteração.

 

Contudo, a informação de descrição de função para eventos do E-Social (S-1030) tem como origem a tabela C8V onde o campo C8V_CODIGO permite até 30 caracteres.


Solução

Verifique via Configurador o volume dos campos V7_DFUNC / RJ_DESC / C8V_CODIGO se estão de acordo com o padrão.

 

mceclip1.png

mceclip2.png

mceclip3.png


Consultar a SX3 via APSDU e verificar o volume de campo nas tabelas SV7/SRJ/C8V

mceclip4.png

Caso algumas desses informações esteja incorreta, deve-se retornar para o volume padrão.

OBS: Se mesmo após as alterações o erro permanecer, verifique se no cadastro de funções possui funções com mais de 20 caracteres cadastradas, se houver será necessário reduzir a nomenclatura para o volume de 20 caracteres.

 

Saiba mais:

RH - Cadastros

 

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _