Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - Linha Protheus - GPE - RDMAKE AltDtSRA



Ocorrência
RDMAKE AltDtSRA

Ambiente
TOTVS RH - TOTVS RH (Linha Protheus) - Gestão de Pessoal - A partir da versão 12.1.17

Causa
Ocorreu de um funcionário estar afastado, ter uma transferência entre filiais por conta de encerramento da filial, após o retorno do afastamento o funcionário foi desligado, porém a matricula da filial origem continuou ativa e os sistema não permite alterar a data de demissão no cadastro de funcionários. 

Solução
Foi criado um RDMake, AltDtSRA, que deve ser compilado e adicionado ao menu do módulo SIGAGPE.

Essa rotina apresenta os funcionários demitidos (RA_SITFOLH = D) e permite alterar apenas os campos Data de Demissão (RA_DEMISSA) e a Situação do Funcionário (RA_SITFOLH) sem executar nenhuma validação nesses campos.

Essa rotina não envia nenhum evento para o eSocial.

Atenção
Só utilize essa rotina em caso de extrema necessidade, pois como as informações não são validadas qualquer alteração pode gerar inconsistência na base de dados.


Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _