Ocorrência
Ao realizar o repasse de atendimento é apresentada a seguinte mensagem: Atendente encontra-se fora do período de trabalho.
Ambiente
Cross Segmentos -TOTVS Aprovações e Atendimentos - Todas as versões
Causa
Esta mensagem é apresentada pelo fato do atendente que recebe o repasse não encontrar-se com status ativo no sistema e/ou estar fora do período de trabalho definido em seu cadastro.
Solução
Alguns cadastros poderão ser avaliados para ajustes desta parametrização:
1. No cadastro de atendente, observe quais são os horários definidos para o mesmo no menu Atendentes - Período de trabalho;
2. Verifique nos parâmetros qual é o horário de repasse definido para o atendente. Parâmetros - Parâmetros para o repasses de atendimentos. Este parâmetro é utilizado para informar ao sistema como ele irá efetuar a validação de horário de serviço do atendente para identificar se o mesmo está ou não fora de seu período de trabalho. As opções são as seguintes:
Horário de expediente fixo: O sistema irá utilizar um horário fixo definido pelo administrador e devidamente cadastrado nos parâmetros do TAA, opção Expediente. Esta validação irá contemplar qualquer atendente. Caso o horário fixo não esteja cadastrado então o sistema irá considerar um horário fixo no código fonte de 06:00 às 18:00, intervalo de 12:00 às 13:00;
Horário de expediente por atendente no RM Agilis: A validação será realizada pelo período de trabalho do atendente que se encontra cadastrado em Período de Trabalho - TOTVS Aprovações e Atendimento - Atendentes - Período de Trabalho. Caso esta opção esteja em uso e não haja período de trabalho para o atendente, então o sistema irá utilizar o horário fixo;
Horário de expediente do atendente/funcionário no Gestão de Pessoas Off-Line: Será verificado o horário do atendente cadastrado no Gestão de Pessoas. A validação será realizada para confirmar se o atendente está fora do horário de trabalho;
Horário de expediente do atendente/funcionário no Gestão de Pessoas On-Line: Será verificado o ponto eletrônico Gestão de Pessoas, se houve batida de entrada/saída pelo atendente/funcionário. E nesta validação, retornará se o atendente encontra-se ou não na empresa no horário de trabalho. Tipo de informação: Valor que representa hora e minuto hh:mm;
Desconsiderar tempo gasto fora do período de trabalho para o cálculo de tempo útil de permanência no histórico de repasse: Quando é executado algum repasse o sistema calcula o tempo que o atendimento ficou com o atendente e insere este tempo útil, na tabela de histórico de repasse. Este cálculo é realizado com base na data em que o atendente recebeu o atendimento ou data de abertura do atendimento, a data que ele está repassando, e o cálculo leva em consideração o horário do atendente por atendente ou horário fixo, observando o calendário com feriados e dias úteis;
3. Outro Parâmetro que poderá ser avaliado, será o relativo aos Parâmetros Gerais de Expediente;
Além de ter a permissão no perfil para cadastrar o período de trabalho, o atendente logado deve ser chefe do atendente para o qual esta tentando cadastrar o período de trabalho. Ou seja, apenas será possível alterar períodos de trabalho de um atendente subordinado ao atendente logado. E o atendente logado, deve ter permissão no perfil de segurança do TAA. Essa subordinação poderá ser tratada na hierarquia associada nos cadastros dos atendentes.


Saiba mais:
Atendentes - TOTVS Aprovações e Atendimentos
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