FAQs - Suporte técnico

RH - Linha Protheus - GPE - XXT10: TOP Error -19 - Field [XX_NOME] not found. ( From tISAMFile::CreateIndex )


Ocorrência
Ao criar índice manual através do Configurador, de forma manual, digitando um campo que não existe na opção de "Campos", por se tratar de campo virtual gera error log.

Exemplo:
Tabela SPY: Preciso criar um índice com o campo PY_NOME (campo virtual), porém o campo não existe na opção Outras Ações ->Campos

mceclip0.png

mceclip1.png

Mesmo assim o índice é criado manualmente, digitando a opção que necessito e ao entrar na rotina gera o error log: SPYT10: TOP Error -19 - Field [PY_NOME] not found. ( From tISAMFile::CreateIndex )

Ambiente
TOTVS RH - TOTVS RH (Linha Protheus) - Gestão de Pessoal - A partir da versão 12.1.17


Causa
O erro ocorre pois nenhum índice pode ser criado se o campo não existir na tela CAMPOS

Solução
Para solucionar essa ocorrência, é necessário que efetue a criação de índices somente com campos disponíveis em: Outras ações -> Campos

Saiba mais
Pacote acumulado RH
12.1.27: https://suporte.totvs.com/portal/p/10098/download?e=954151
12.1.33: https://suporte.totvs.com/portal/p/10098/download?e=1039093 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _