Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.
Base de Conhecimento

Framework - Linha Datasul - FRW - Falha na Renderização na geração de relatórios PDF

Framework - Linha Datasul - FRW - Falha na Renderização na geração de relatórios PDF

time.png Tempo aproximado para leitura: 00:03:18 min

Ocorrência
Durante a execução de um relatório gráfico desenvolvido pelo Dataviewer, na geração do arquivo PDF - Portable Document Format  é apresentada a mensagem Falha na renderização! Verifique o relatório e os logs da sessão ou entre em contato com o suporte.

Ambiente
Framework - Framework (Linha Datasul) – DataViewer (DVW) – Versão 12

Causa
Esta mensagem ocorre na máquinas onde o Java e\ou o Acrobat Reader não estão devidamente instalados ou configurados.

São pré-requisitos:
- Java Run Time 1.4.2 ou superior;
- Acrobat Reader;
- Variáveis de ambiente JAVA_HOME, PATH e CLASSPATH devidamente configurados.

Solução
Segue abaixo como realizar a configuração das variáveis de ambiente conforme a versão do Windows:

Para Windows 10:
1. Pressione com o botão direito do mouse sobre o menu Iniciar do Windows, e selecione a opção Sistema;
2. Com a tela selecionando a opção Sobre, localize a opção Informações do Sistema e clique sobre a mesma;
3. Na tela Sistema, clique em Configurações avançadas do Sistema;
4. Na tela de Propriedade do Sistema, selecione a opção Avançado e em seguida clique em Configurações;
5. No bloco Variáveis do Sistema, verifique se consta as variáveis JAVA_HOME e CLASSPATH. Havendo, edite as mesmas para a configuração desejada; caso não exista, pressione o botão Novo, informe a variável JAVA_HOME informando o diretório de instalação do JAVA. Clique em Novo novamente, informe a variável CLASSPATH e no campo de valor informe .;%JAVA_HOME%;
6. Localize a variável de ambiente PATH, edite o seu valor e adicione no fim ;%JAVA_HOME%\bin;
7. Reinicie o seu computador para aplicar a nova configuração.

Para Windows XP:
1. Clique em Iniciar, em seguida Painel de Controle e selecione Sistema;
2. Na janela apresentada, acione a aba Avançado e depois clique em Variáveis de Ambiente;
3. Na próxima tela, clique em Adicionar;
4. Insira as variáveis JAVA_HOME e CLASSPATH com os respectivos valores, da mesma forma como apresentado na configuração para o Windows 10;
5. Para alterar a PATH, basta editá-la e adicionar no fim: ;%JAVA_HOME%\bin.
6. Reinicie o seu computador para aplicar a nova configuração.

Importante
Esta configuração do Java e Acrobat Reader deverá ser aplicada em todas as máquinas no qual o relatório será emitido. Para verificar se as configurações foram realizadas corretamente, execute o comando cmd - prompt de comando e digite:  java -version. Deverá ser retornada a versão do Java configurada nos procedimentos descritos acima. 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _