Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS Backoffice Linha Protheus - ADVPL - Host não encontrado FwRest

time.pngTempo aproximado para leitura: 00:02:00 min

Ocorrência

Estou utilizando a Classe FwRest(), porém retorna erro:

Host não encontrado


Ambiente

Cross Segmentos - Backoffice (Linha Protheus) – ADVPL – A partir da versão 12.1.17

Causa
esse erro significa que causou um problema no recurso interno utilizado para identificar os valores dos headers. Como os headers também fazem parte da requisição, é preferível cancelar todo o processo, do que permitir seguir.
Como sempre, os casos que envolvem ferramentas de terceiros (Postman, Insomnia, SoapUi, curl, etc) precisam ter sua relevância reconsiderada pois eles implementam serviços e tratamentos que podem não fazer sentido para funções do ERP.

Solução
Como alternativa, utilize a função HTTPGET, para realizar a requisição, pois ela não valida o header

Saiba mais
HttpGet

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _