Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - RM - FOP - Tentativa de divisão por zero / Attempted to divide by zero


time.png
Tempo aproximado para leitura: 00:01:30 min

Ocorrência
Ao acessar o envelope de um funcionário, é retornado o erro: Tentativa de divisão por zero ou, em inglês Attempted to divide by zero.

mceclip0.png

Ambiente
TOTVS RH - TOTVS RH (Linha RM) - TOTVS Folha de Pagamento - Todas as versões

Causa
Este erro ocorre, em geral, quando o funcionário é comissionista e/ou seu salário é igual a zero. Em resumo, ao acessar o envelope, o sistema executa um recálculo antes de apresentar as informações. Ao tentar recalcular eventos com fórmula que buscam o salário do funcionário, como seu salário é zero, o sistema não conseguirá executar o recálculo e retornará a mensagem supracitada.

Solução
Sendo a causa do problema a estruturação de fórmulas, a solução terá caráter manual, ou seja, será necessário identificar qual fórmula busca ou faz referência ao salário do funcionário para que seja reestruturada. Sugere-se o apoio da equipe de TI da empresa para auxiliar na correção ou, caso prefira, acionar nosso serviço de consultoria tarifada, onde um consultor estará à disposição e poderá auxiliar e corrigir o problema.

Esse artigo foi útil?
Usuários que acharam isso útil: 1 de 1

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _