Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

WINT - 1301 - ORA-00001: unique constraint (XXX.PCMOVHISTORICO_PK) violated

time.pngTempo aproximado para leitura: 00:03:00 min

 

Ocorrência
No processo de gravar a nota de entrada na rotina 1301, apresenta o seguinte erro:

mceclip0.png

Ambiente
TOTVS Distribuição Linha Winthor - 13 - Recebimento de Mercadoria -  A partir da versão 30

Causa
Essa mensagem ocorre ao executar uma instrução INSERT ou UPDATE que criou um valor duplicado em um campo restrito por um índice exclusivo.

Solução
Para corrigir, realize os passos abaixo:
1. Atualizar a rotina 560 e 500 para ultima versão disponível no CCW;
2. Agora, abra a rotina 500;
3. Execute as opções:

  •  27- Pacote de geração de historico fiscal(GERA_HISTORICO);

500_1.gif

  • 105- Tigger de gravação Históricos na movimentação(PCMOVHISTORICO)

500_2.gif

4. Em seguida, acesse a rotina 560;

560_1.gif
5. Selecione a opção PCMOVHISTORICO e clique Confirmar;

6. Refaça o processo na rotina 1301.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _