FAQs - Suporte técnico

DS - THF - Erro Interno e Erro de Negócio ao Acessar o Datasul THF

relogio.png Tempo aproximado para leitura: 00:02:18 min

Ocorrência
Ao acessar o Datasul THF, após o login, são apresentados os erros:
Erro Interno - O servidor encontrou um erro interno e não pôde concluir sua solicitação. Entre em contato com o Administrador.
Erro de Negócio - INTERNAL Internal server error.

Ambiente
Datasul – Tomcat – A partir da versão 12.1.26

Causa
Arquivo .pf e/ou de alias incorretos no AppServer da sessão.

Solução
No Datasul THF - TOTVS HTML Framework faz-se necessário no arquivo .pf todas as conexões com os bancos de dados e no arquivo .p todos os alias.  

Esses arquivos são apresentados nas linhas srvrStartupParamsrvrStartupProc do AppServer, conforme exemplo:

[UBroker.AS.totvs-brk-FND]
appserviceNameList=totvs-brk-FND
autoStart=1
.....
srvrStartupParam=-pf C:\TOTVS\datasul\thf\instance-8180\scripts-8180\totvs-brk-FND.pf
srvrStartupProc=C:\TOTVS\datasul\thf\instance-8180\scripts-8180\totvs-brk-FND-alias.p
....

Exemplo parcial de arquivo .pf, onde pode-se notar todos os bancos dos ambiente:

-mmax 1000
-s 1024
-TB 31
-TM 32
-d dmy
-Bt 2048
-tmpbsize 8
-Mm 4096
-cpstream ibm850
-q
-h 100
-numsep 46
-numdec 44

#@Inicio
-db emsfnd -ld emsfnd -S 23619 -H JVN019401772 -N tcp
-db cad2loc -ld cad2loc -S 23635 -H JVN019401772 -N tcp
-db cad5loc -ld cad5loc -S 23639 -H JVN019401772 -N tcp
-db eai -ld eai -S 23621 -H JVN019401772 -N tcp
-db eai2 -ld eai2 -S 23623 -H JVN019401772 -N tcp
-db ems5cad -ld emscad -S 23605 -H JVN019401772 -N tcp
....

Exemplo parcial do arquivo de alias, onde está relacionada a unificação dos bancos:

DEFINE INPUT PARAMETER v-parameter AS CHAR NO-UNDO.

CREATE ALIAS emsbas FOR DATABASE emscad.
CREATE ALIAS emsedi FOR DATABASE emscad.
CREATE ALIAS emsfin FOR DATABASE emscad.
CREATE ALIAS emsuni FOR DATABASE emscad.
CREATE ALIAS emsven FOR DATABASE emscad.
CREATE ALIAS movfin FOR DATABASE emsmov.
...

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _