FAQs - Suporte técnico

Cross Segmentos - Linha Datasul - NFE - Falha de Schema XML: EANCode

time.png Tempo aproximado para leitura: 00:01:10 min

Ocorrência
Ao enviar a nota fiscal ocorre a mensagem: Element '{http://www.portalfiscal.inf.br/nfe}cEAN

Ambiente
Cross Segmentos - TOTVS Backoffice (Linha Datasul) - Nota Fiscal Eletrônica (NFE) - Todas as versões

Causa
Essa validação ocorre quando a nota não possui a informação do código EAN - European Article Number no XML.

Solução
No programa CD0903 - Atualização Itens Faturamento existe um campo para que seja informado o código EAN do item. Esse campo fica na pasta Fiscal campo GTIN.

O código EAN deve possuir 8, 12 ,13 ou 14 caracteres, e caso o produto não tenha este código não será informado este campo no arquivo XML.

Caso não exista valor informado, basta deixar o campo em branco que ele não será levado para o XML da nota.

Se for informado um valor, ele precisa ser válido, caso contrário a SEFAZ - Secretaria da Fazenda irá rejeitar a nota.

Ao informar esse valor o mesmo será levado no XML para processamento da SEFAZ  para as tags cEAN e cEANTrib.

O campo GTIN pode ser encontrado nos programas CC0103 - Manutenção itens Compras e CD0903.

Para verificar quais os itens que estão com o código GTIN informado, execute o comando abaixo no editor do Progress, tendo a listagem, verifique se este valor informado está correto ou não.

Execute o Editor do Progress, através do CTRL+ALT+X digite _edit.r e copie e cole o comando abaixo e tecle F2, ao final será gerado a listagem no c:\tmp\Codigo_EAN.txt ou qualquer diretório informado diretamente no programa:

OUTPUT TO "c:\tmp\Codigo_EAN.txt".
     FOR EACH ITEM WHERE SUBSTRING(ITEM.char-1,133,14) <> "":
     DISP ITEM.it-codigo
          SUBSTRING(ITEM.char-1,133,14).
 END.
OUTPUT CLOSE.

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

1 Comentários

  • Avatar
    Marcos Roberto Pedrao

    olá, esse for each não funciona mais pois o gtin atualizado está no campo item-mat.cod-ean.

    0
    Ações de comentário Permalink
Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _