Ocorrência
Erro na validação do arquivo CNAB junto ao banco (erro no layout ou erro de linha inválido)
Ambiente
TOTVS RH - TOTVS RH (Linha Protheus) - Gestão de Pessoal - A partir da versão 12.1.17
Causa
Se o arquivo CNAB já foi validado em outro envio, esse incidente pode ocorrer, devido à configuração do grupo de perguntas da rotina GPEM080 (Geração de líquidos).
Solução
Exemplo de erro apresentando na validação do arquivo CNAB:
Para solucionar essa ocorrência, realize os seguintes passos:
1. Acesse Miscelânea ->Líquido -> Geração de Líquidos:
2. Nas perguntas da rotina, verifique o campo : Linha vazia no Final do Arquivo e configure com NÃO:
3. Em seguida , gere o arquivo CNAB novamente e refaça a validação junto ao banco.
IMPORTANTE: Tratando-se de layout do arquivo CNAB, caso não seja possível solucionar esse problema, é provável que seja necessário apoio para validação e configuração do arquivo, solicitando a visita de um consultor in loco para realizar tal procedimento, uma vez que para as verificações deste atendimento e validações do arquivo são realizados somente através de consultoria por um analista desenvolvedor.
ATENÇÃO: Muita atenção ao revalidar o arquivo gerado junto ao banco, para que não ocorra a tentativa de revalidação com o arquivo incorreto, de modo que apresente o mesmo erro.
0 Comentários