Ocorrência
Ao realizar a impressão de um boleto e habilitar a opção "Gerar um arquivo para cada boleto" o sistema exibe o seguinte erro:
Diretorio padrão '' não encontrado! Favor verificar nos arquivos de configuração do RM.EXE (rm.exe.config) se a TAG abaixo para a redireciar os arquivo para um único diretório na rede se encontra configurada.
Exemplo:
<add key="FileServerPath" value="C:\RM"/>
Ambiente
Cross Segmentos - Backoffice Linha RM - TOTVS Gestão Financeira - A partir da versão 11.8x
Causa
Atualmente não existe a possibilidade de definir um caminho para geração do arquivo na tela de impressão de Boletos quando se utiliza um relatório do RMReports sendo necessário parametrizar um caminho padrão a ser utilizado.
Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Crie uma pasta compartilhada com TODOS e com permissão total (leitura e gravação);
2. Finalize todos os aplicativos TOTVS que estejam iniciados (caso seja N camadas deverá encerrar a aplicação em todas as máquinas);
3. Acesse o diretório: C:\totvs\CorporeRM\RM.Net;
4. Execute o aplicativo: RM.Host.ServiceManager.exe;
5. Habilite a opção Apagar _Broker.dat e clique em Desinstalar;
6. Ainda no diretório RM.net, localize e edite o arquivo RM.exe.config;
7. Acrescente a TAG <add key="FileServerPath" value="\\SERVIDOR\NOMEDAPASTA\"/>
8. Salve esta alteração e feche o arquivo;
9. Ainda na pasta RM.net, execute novamente o aplicativo RM.Host.ServiceManager.exe;
10. Clique em Instalar;
11. Acesse o RM.exe, confirme se o caminho informado foi apresentado na tela de impressão de boletos e conclua a impressão;
0 Comentários