Ocorrência
[Exemplo:
Ao efetuar a consulta F3 do produto, seja no chamado técnico(TECA300), orçamento (TECA400) e Ordem de Serviço (TECA450), está ocorrendo lentidão.
Ambiente
Microsiga Protheus - a partir da release 12.1.17.
Causa
O problema ocorreria por que a consulta padrão AA3 estava com problemas de performance , desta forma, foi criado uma nova consulta na AA3 para efetuar a busca dos dados direto do Banco de Dados.
Solução
A correção desta ocorrência já está contida no último Pacote de Expedição Contínua do módulo! Segue para aplicação após backups e validação em ambiente teste:
https://suporte.totvs.com/portal/p/10098/download#all/all/all/search/gs_expedicao_continua
O teca450 é datado de 29.11.2019, onde a correção já havia sido efetuada.
Além disso, é preciso efetuar a alteração da consulta padrão AA3,filtro @#AT450FL2() na sua consulta padrão, conforme a imagem abaixo da minha consulta padrão da AA3 e documentação da issue https://tdninterno.totvs.com/pages/viewpage.action?pageId=521653550 para que não ocorra a lentidão no ambiente:
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