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Cross Segmentos - Linha Logix - SUP - Mensagem Não existe contrato válido p/ este item/fornecedor no SUP4330/SUP22104

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Ocorrência
Ao processar a rotina SUP4330/SUP22104 - Elaboração automática de pedidos de compras é apresentada a mensagem Não existe contrato válido p/ este item/fornecedor no relatório de consistências.

Ambiente
Cross Segmentos - TOTVS Backoffice (Linha Logix) - Compras - Versão 12

Causa
Essa divergência ocorre quando o Sistema não localiza um contrato válido para a ordem que está sendo processada.

Solução
Para que não ocorra essa mensagem é necessário que no SUP2410/SUP21005 - Participação do fornecedor nas compras, que também pode ser acessado pelo SUP0120 - Cadastro de preços opção 1-participação nas compras ou SUP21004 - Cadastro de preços opção Participação Compras, exista um cadastro para o item e fornecedor da ordem de compra, onde a data de entrega esteja dentro de um período vigente e seja igual ao período do contrato no SUP0120/SUP21004 assim como o tipo de contrato do mesmo, que pode ser 1-Pedido Fechado, 4-Pedido Aberto ou 3-Consignação caso o parâmetro Emite pedido remessa automático do SUP7170 - Parâmetro Consignação estiver marcado.

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