Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

WINT - Ora -01400 cannot insert NULL Into (''xxxxxx''.''pcpedi''.''Pvenda'') nas rotinas 2596 e 3330.

Ocorrência
Ao acessar as rotina 2596 - Integração Dados Externos e 3330 - Relatórios de Integradora é apresentada a seguinte mensagem: Ora -01400 cannot insert NULL Into (''xxxxxx''.''pcpedi''.''Pvenda'').

Ambiente
WinThor - Vendas - Aplicável a partir da versão 29

Causa
Esse incidente ocorre normalmente porque no momento da integração do pedido não foi localizado preço para o produto naquela filial/região.

Solução
Para resolver essa mensagem, realize os procedimentos a seguir:

Verifique os parâmetros 1065 - Trabalha com preço por embalagem e 2257 - Utilizar preço de venda por embalagem (por filial) na rotina 132 - Parâmetros da PresidênciaSe algum deles estiver marcado como Sim, será necessário realizar a precificação do produto através da rotina 2017 - Precificação por embalagem. Caso contrário, prossiga da seguinte forma:

1. Acesse a rotina 201 - Precificar Produto, preencha os campos conforme necessidade e clique Pesquisar;
2. Na tela de precificação, verifique se a região possui o Preço futuro informado, caso contrário preencha-o;
3. Pressione a tecla F8 para que seja efetuado recálculo do produto;
4. Clique Aplicar preços para venda externa;
5. Será apresentada a tela  Aplicar preços para venda externa marque as opções Todos os produtos filtrados e Todas as regiões filtradas.
6. Em seguida clique Confirmar.

 

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _