Tempo aproximado para leitura: 00:02:23 min
Ocorrência
Após alteração de endereço IP - Internet Protocol do servidor de aplicação, o Jboss não inicia corretamente, sendo que o log armazena apenas informações relacionadas ao início do processo de carga.
Ambiente
Framework - Framework (Linha Datasul) - JBoss – Todas as versões
Causa
Havia problema relacionado a comunicação com outras instâncias na mesma rede, por conta da configuração de Cluster do produto.
Solução
Foi identificado que o log em modo INFO era interrompido logo no início da carga, antes mesmo de mostrar as informações de rede. Isso indica que houve algum problema relacionado a configuração de rede utilizada pelo Jboss para comunicação com outras instâncias existentes na mesma rede. Esta comunicação é realizada através de um endereço Multicast configurável no script de carga do serviço.
Para realizar esta alteração, siga os passos abaixo:
1. Edite o arquivo service-8x80.bat da instância em questão, localizado no diretório bin do Jboss;
2. Localize neste arquivo a string -b 0.0.0.0;
3. Insira após a string acima o parâmetro -u seguido de um endereço de Multicast a ser utilizado. Exemplo: 235.235.235.100. Abaixo exemplo desta configuração:
-b 0.0.0.0 -u 235.235.235.100
Esta configuração existe em dois pontos diferentes deste arquivo. Altere as duas entradas;
4. Salve o arquivo e inicie novamente o Jboss.
Este procedimento pode ser realizado para todas as instâncias do Jboss existentes na rede, bastando apenas alterar o IP Multicast a ser utilizado, como nos exemplos abaixo:
Exemplo servidor 1: -b 0.0.0.0 -u 235.235.235.100
Exemplo servidor 2: -b 0.0.0.0 -u 235.235.235.101
Exemplo servidor 3: -b 0.0.0.0 -u 235.235.235.102
Exemplo servidor 4: -b 0.0.0.0 -u 235.235.235.103
0 Comentários