Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - Linha Datasul - TSA - TSA não conecta com o banco de dados SQL Server

relogio.png Tempo aproximado para leitura: 00:01:00 min

Ocorrência
TSA não conecta com o banco de dados SQL Server e ocorre o Erro O driver não pôde estabelecer uma conexão segura com o SQL Server usando a criptografia SSL

Ambiente
TOTVS RH - TOTVS RH (Linha Datasul) - Segurança e Acesso (TSA) - Versão 12  

Causa
Esse erro ocorre, pois o servidor possuí alguma atualização do certificado de segurança feita pela Microsoft. Como o TSA ainda não está preparado para trabalhar com criptografia, acaba ocorrendo o erro em log e o TSA não consegue estabelecer conexão com o banco de dados.
Erro que ocorre no Log do JBOSS TSA:

image2016-7-12_13_59_17.png

Há principio identificamos dois pacotes de atualização pela Microsoft que geram esse problema: KB3163018 e KB3163017. Porém pode ter algum outro que gere o mesmo erro.

Solução
Remover os pacotes de atualização da Microsoft. Feito esse procedimento o TSA voltará a conectar com o SQL Server

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _