Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha Datasul - TEC - Foreign database cursor 0 not found 1471

time.png Tempo aproximado para leitura: 00:01:18 min

Ocorrência
Na execução da rotina e no arquivo de log é apresentada a mensagem SYSTEM ERROR: Foreign database cursor 0 not found. (1471)

Ambiente
Framework - Framework (Linha Datasul) - Oracle - Todas as versões

Causa
O parâmetro -c definido no arquivo .pf é muito baixo para o processamento. O OpenEdge Dataserver utiliza cursores para acessar o banco de dados Oracle. O erro ocorre devido a quantidade parametrizada de cursores ser menor que a necessária ou ser superior ao permitido, que é 65000.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:

1. Identifique o número de cursores atual no Oracle, executando o comando:

show parameter open_cursors;


2. Aumente o número de cursores, conforme exemplo:

alter system set open_cursors = 30000 scope=both


3. No programa Parâmetros Foundation - btb962aa ajuste o parâmetro -c no cadastro de cada banco de dados cadastrado de todas as empresas;

4. No arquivo ..\erp\scripts-8x80\datasul.pf ajuste o parâmetro -c do banco emsfnd. Esse banco é utilizado para todas as empresas.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _