Ocorrência
No módulo SmartECF, ao tentar selecionar o cliente para realizar uma venda é apresentada a mensagem Cliente não será associado à venda:

Ambiente
Gemco Anywhere - SmartECF - À partir da versão 41 SP 17
Causa
Esse incidente ocorre, pois o Sistema foi parametrizado para LGPD, onde o cliente não deu o consentimento para utilização dos seus dados.
Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Ao informar um CPF já cadastrado o SmartECF realizará uma pesquisa dos dados do cliente, e nesse momento ele realizará uma validação para verificar se o cliente já deu o consentimento da utilização dos dados. Caso o mesmo ainda não tenha dados, uma mensagem será exibida para que o operador de caixa pergunte ao cliente:

Obs.: Caso não aparece essa tela da Carta de Consentimento, verificar no C:\Windows\SysWOW64 (64bits) ou C:\Windows\System32 (32bits) se tem a ocx "Richtx.ocx" (é do windows), caso não tenha, copiar de outra maquina.
Precisa registrar essa ocx:
Digite o seguinte comando na caixa de diálogo "Executar". : (se for windows 10 precisa ser como administrador)
regsvr32 C: \Windows\Syswow64\Richtx.ocx
Pressione "Enter" para confirmar o registo Richtx.ocx
2. Se o cliente informar ao operador que concorda com o consentimento, o operador deve pressionar F10 para confirmar, essa informação já será gravada no banco de dados.
Caso o cliente não concorde com o consentimento, basta pressionar ESC, nesse momento uma mensagem será exibida e o cliente não será associado a venda.
Importante:
Essa regra se aplica apenas à clientes pessoa física, os clientes pessoa jurídica não serão validados e no cadastro simplificado não serão salvos.
0 Comentários