Ocorrência
Aconselhamos o envio dos arquivos abaixo para a abertura de novas solicitações.
1 - Console.log
2 - Error.log (caso apresente algum erro)
3 - Log gerado pelo LogProfiler
4 - Inspetor de objetos
5 - "Evidencia do processo"
Obs.: Para o envio dos arquivos, solicitamos que seja realizado backup's dos mesmos, sejam renomeados e nos enviar os novos arquivos gerados no processo.
Ambiente
TOTVS Saúde - Planos - Linha Protheus - SIGAPLS plano de Saúde - A partir da versão 12.1.17
Causa
Abertura de novas solicitações.
Solução
Arquivo LogProfiler: Ferramenta que permite identificar tempos de execução das rotinas. Utilizada principalmente para identificação de possíveis problemas de desempenho. Deve-se utilizá-lo apenas em situações de necessidade de diagnóstico, pois durante sua execução, o sistema se tornará mais lento, devido a todas as execuções serem monitoradas e logadas. Para executar, siga os passos abaixo:
• Passo 01 Na tela LogProfiler, clique no botão Iniciar. A partir deste momento o ambiente estará sendo monitorado, pode fechar a tela do SHIFT+F6 (Cancelar ou Concluir), e então reproduza a sequência das telas que deseja logar. * Aviso: A reprodução deve ser feita no mesmo Smartclient que está aberto. O que reproduzir em outro Smartclient não será capturado neste log. Se fechar este Smartclient, o processo é interrompido e deverá ser iniciado novamente.
• Passo 02 Ao término da sequência, abra novamente a tela do SHIFT+F6, vá até a tela Rastrear fontes, então clique em Finalizar.
• Passo 03 Na tela que irá abrir, selecione a pasta onde deseja salvar o arquivo e clique em Salvar * INFORMAÇÃO: O log é feito por thread. O Programa Inicial SIGAADV e o Programa Inicial que chama diretamente os módulos (SIGACOM por exemplo) abre apenas uma thread, sem abas. Já o SIGAMDI abre uma thread por aba aberta. Desta forma, o log valerá apenas para a aba aberta em que for iniciado.
Saiba mais: Para mais informações, acesse o link: Em caso de nova ocorrência
0 Comentários