Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

MP - TOTVS PDV - VENDAS NÃO INTEGRAM COM RETAGUARDA

Ocorrência
Ao finalizar um orçamento em ambiente TOTVS PDV, venda não integra com ambiente Retaguarda

Ambiente
Microsiga Protheus – SIGAFRT/TOTVS PDV – A partir da versão 12.1.17

Causa 
Esse incidente ocorre, pois cadastros em configuração de HOST ou cadastro de Estação estão incorretos.

Solução
1. Consulte o atalho do Smartclient ou WebAgent do TOTVS PDV e valide se parâmetro corresponde ao cadastro de estação.

Exemplo Smartclient:
-M -E=TOTVS_PDV -P=SIGAFRT -C=TCP -A= -A=001

Exemplo WebAgent:
C:\Users\administrador\AppData\Local\Programs\web-agent\web-agent.exe launch "http://192.168.0.1:4324?E=TOP2410&A=&A=001&M" --browser="C:\Program Files\Google\Chrome\Application\chrome.exe"
 

mceclip0.png
 

2. Verifique a chave STWUpData, em appserver.ini de TOTVS PDV, a mesma deve estar contida em na chave ONSTART, e Parm3 deve corresponder a estação utilizada.

[ONSTART]
JOBS=STWUpData
RefreshRate=30

[STWUpData]
Main=STWUpData
Environment=TOTVS_PDV
nParms=
Parm1=01 
Parm2=01 
Parm3=001

Obs.: Caso esteja fazendo uso da chave [STWUPSALE], a mesma validação deve ser realizada em Parm3.
 

3. Validações em cadastro de HOST:
Via APSDU as seguinte validação devem ser realizadas nas tabelas XXZ e XXY:

-Tabela XXZ - Deve conter apenas funcionalidades apontando para o ambiente MASTER. Caso exista alguma funcionalidade apontando para o ID do PDV, a mesma deve ser apagada. (ID de TOVS PDV pode ser validado a partir de chave [FWCOMMUNICATION], contido em appserver.ini de PDV).

-Tabela XXY - Campo XXY_STATUS deve estar cadastrado como em todos as funcionalidades cadastradas.

-Tabela XXX - Campo XXX_ENABLE deve estar igual a para utilização do WEBService RPC (PDV e Retaguarda)

Certifique-se que Pacote Acumulado Varejo esteja aplicado em ambiente PDV e Retaguarda:
Acumulado Varejo
Caso servidor possua Slaves, certifique-se que todos ambientes estejam apontando para o mesmo RPO ou com as mesmas atualizações. 



Saiba Mais:
Desvendando o TOTVS PDV
TOTVS PDV - GUIA DE SUPORTE
MP - Totvs PDV - Como otimizar o processo de subida de vendas

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _