Ocorrência
Ao finalizar um orçamento em ambiente TOTVS PDV, venda não integra com ambiente Retaguarda
Ambiente
Microsiga Protheus – SIGAFRT/TOTVS PDV – A partir da versão 12.1.17
Causa
Esse incidente ocorre, pois cadastros em configuração de HOST ou cadastro de Estação estão incorretos.
Solução
1. Consulte o atalho do Smartclient ou WebAgent do TOTVS PDV e valide se parâmetro corresponde ao cadastro de estação.
Exemplo Smartclient:
-M -E=TOTVS_PDV -P=SIGAFRT -C=TCP -A= -A=001
Exemplo WebAgent:
C:\Users\administrador\AppData\Local\Programs\web-agent\web-agent.exe launch "http://192.168.0.1:4324?E=TOP2410&A=&A=001&M" --browser="C:\Program Files\Google\Chrome\Application\chrome.exe"
2. Verifique a chave STWUpData, em appserver.ini de TOTVS PDV, a mesma deve estar contida em na chave ONSTART, e Parm3 deve corresponder a estação utilizada.
[ONSTART]
JOBS=STWUpData
RefreshRate=30
[STWUpData]
Main=STWUpData
Environment=TOTVS_PDV
nParms=3
Parm1=01
Parm2=01
Parm3=001
Obs.: Caso esteja fazendo uso da chave [STWUPSALE], a mesma validação deve ser realizada em Parm3.
3. Validações em cadastro de HOST:
Via APSDU as seguinte validação devem ser realizadas nas tabelas XXZ e XXY:
-Tabela XXZ - Deve conter apenas funcionalidades apontando para o ambiente MASTER. Caso exista alguma funcionalidade apontando para o ID do PDV, a mesma deve ser apagada. (ID de TOVS PDV pode ser validado a partir de chave [FWCOMMUNICATION], contido em appserver.ini de PDV).
-Tabela XXY - Campo XXY_STATUS deve estar cadastrado como 2 em todos as funcionalidades cadastradas.
-Tabela XXX - Campo XXX_ENABLE deve estar igual a 1 para utilização do WEBService e RPC (PDV e Retaguarda)
Certifique-se que Pacote Acumulado Varejo esteja aplicado em ambiente PDV e Retaguarda:
Acumulado Varejo
Caso servidor possua Slaves, certifique-se que todos ambientes estejam apontando para o mesmo RPO ou com as mesmas atualizações.
Saiba Mais:
Desvendando o TOTVS PDV
TOTVS PDV - GUIA DE SUPORTE
MP - Totvs PDV - Como otimizar o processo de subida de vendas
0 Comentários