Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Linha Datasul - FGL - Erro 22243: Não podem haver itens de lançamento com valor zero

time.png Tempo aproximado para leitura: 00:03:15 min

Ocorrência
Na execução do programa FGL715 ocorre a mensagem 22243: Não podem haver itens de lançamento com valor zero!
No relatório gerado, é apresentada a ocorrência 19.856: Interrupção da contabilização do lote.

Ambiente
Cross Segmentos - TOTVS Backoffice (Linha Datasul) - Contabilidade Fiscal (FGL) - Versão 12

Causa
Problemas de parametrização no critério de distribuição da conta contábil podem ocasionar a ocorrência de mensagens de erros ao executar o programa FGL715 - Apuração Lucros e Perdas (prgfin/fgl/fgl715aa.r).

Solução
Avaliar cada conta contábil vinculada a itens com valor igual a zero, e verificar a necessidade de ajuste da parametrização no programa programa UFN015 - Critério Distribuição Centro de Custo (prgint/ufn/ufn015aa.r)

Exemplo da ocorrência dos erros:

image2017-2-24_15_35_51.png

image2017-2-24_15_37_27.png

Para verificar todas as ocorrências de itens zerados, acessar o programa no programa FGL702 - Manutenção Lançamentos Contábeis (prgfin/fgl/fgl702aa.r) e posicionar no lote gerado pela rotina:

image2017-2-24_15_38_28.png

Para cada conta com valor zerado, confirmar a existência de saldos com centro de custo através emissão do relatório FGL307 - Balancete (prgfin/fgl307ab.r). Na opção Mais, desmarcar o parâmetro Sumaria por Centro de Custo e Estabelecimento.  Deve ser marcada a opção Mostra Contas sem Apropriação de C.Custo.

image2017-2-24_15_59_18.png

Normalmente o problema ocorre quando existem saldos na conta contábil vinculados e não vinculados a centro de custo. Os procedimentos de ajustes seguir as orientações do artigo Cross Segmentos - Linha Datasul - FGL - Após apuração algumas contas de resultado não foram zeradas, tópicos 2 e 3:
2. Validar a faixa atual do critério de distribuição da conta.
3. Efetuar lançamento de transferência dos saldos para o critério atual.

Em caso de dúvidas ou se não identificar problema na parametrização, encaminhar os anexos listados abaixo, para análise da equipe de Suporte Controladoria:

  • FGL308AA - Relatório do lote contábil (prgfin/fgl/fgl308aa.r), na seleção incluir o número lote e definir  Nível Impressão igual a Apropriação e Situação lote/lanç igual a Todos;
  • UFN015 - Critério Distribuição Conta Contábil, posicionar em cada conta contábil com valor do lançamento igual a zero, exportar os dados para o excel, comando Ctrl+alt+e;
  • Emitir o balancete completo através do programa FGL307, marcar a opção Imprime parâmetros, no botão Mais, desmarcar a opção Sumaria Centro de Custo e Estabelecimento, marcar a opção Mostra Contas sem Apropriação de C.Custo, Considera Apuração de Resultados e Somente Contas Analíticas

Após ajustes, eliminar o lote pendente e realizar novamente a execução do programa FGL715.

Para confirmar a contabilização do lote de apuração, acessar o programa FGL201 - Consulta Lote Contábil (prgfin/fgl/fgl201aa.r). O lançamento contabilizado tem a indicação de situação igual a Ctbz.

image2017-2-24_15_38_55.png

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _