Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.
Base de Conhecimento

Cross Segmentos - Linha Logix - OBF - OBF0476 GIA SP - Tabela 02, CR=05, Campo - IE Inconsistente, Posição 3

Cross Segmentos - Linha Logix - OBF - OBF0476 GIA SP - Tabela 02, CR=05, Campo - IE Inconsistente, Posição 3

time.png Tempo aproximado para leitura: 00:02:40 min

Ocorrência
Ao validar o arquivo da GIA SP ocorre o erro: Tabela 02, CR=05, Campo - IE Inconsistente, Posição 3.

Ambiente
Cross Segmentos - TOTVS Backoffice (Linha Logix) - Legislação Estadual - Versão 12

Causa
O erro de validação ocorre, pois o cadastro da empresa não tem o código da Inscrição Estadual

Solução
Realize os procedimentos a seguir para corrigir o erro de validação da GIA SP no registro CR=05:

  1. Acesse o LOG00083, e preencha o campo Inscrição Estadual.
    Ao alterar os dados da empresa é gerado o histórico da alteração na tabela empresa_hist, por isso a nova IE será utilizada a partir da data de atualização. Então se a GIA SP em processamento é do período anterior a alteração, é necessário realizar o ajuste na tabela de histórico via banco de dados, conforme os procedimentos a seguir: 

    1. Execute o comando SQL, para encontrar o último período de histórico da empresa na tabela empresa_hist:
      SELECT MAX(dat_validade_fim)
      FROM empresa_hist
      WHERE cod_empresa = 'XX'
      AND (dat_validade_ini <= '31/XX/XXXX 23:59:59'
      AND dat_validade_fim >= '01/XX/XXXX 00:00:00')
      Onde: 
      • XX = informe o código da sua empresa;
      • 31/XX/XXXX 23:59:59 = informe a data final do período em processamento na GIA SP e mantenha o horário;
      • 01/XX/XXXX 00:00:00 = informe a data inicial do período em processamento na GIA SP e mantenha o horário.

    2. Execute o comando SQL, para alterar a IE na tabela empresa_hist:
       UPDATE empresa_hist 
      SET ins_estadual = '99999999'
      WHERE cod_empresa = 'XX'
      AND dat_validade_fim = 'XX/XX/XXXX XX:XX:XX'
      Onde: 
      • 99999999 = informe a nova IE;
      • XX = informe o código da sua empresa;
      • XX/XX/XXXX XX:XX:XX = informe a data e a hora que retornou no SQL do item 1. 
         
    3. Execute o comando SQL, para confirmar a alteração da IE na tabela empresa_hist:
      SELECT cod_empresa, ins_estadual
      FROM empresa_hist
      WHERE cod_empresa = 'XX'
      AND dat_validade_fim = 'XX/XX/XXXX XX:XX:XX'
      Onde: 
      • XX = informe o código da sua empresa;
      • XX/XX/XXXX XX:XX:XX = informe a data e a hora que retornou no SQL do item 1. 

  2. Execute o OBF0476, para gerar o arquivo da GIA SP com a IE preenchida no registro CR=05.


Glossário 

GIA Guia de Informação e Apuração 
SP - São Paulo 
IE - Inscrição Estadual 
CR - Código de Registro
LOG00083 - Cadastro de Empresa 
OBF0476 - Gera Lote da GIA de SP

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _