Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

WINT - ORA-00904: "P"."CODPRODANTUTICAD": invalid identifier.

time.pngTempo aproximado para leitura: 00:01:30 min

 

Ocorrência
Ao realizar faturamento é apresentada a mensagem: ORA-00904: "P"."CODPRODANTUTICAD": invalid identifier.

 

Ambiente
TOTVS Distribuição Linha Winthor - 1 - Plano de Voo -  A partir da versão 30

Causa
Esse incidente ocorre devido à falta de parametrização necessária para o faturamento em questão.

Solução
Para resolver essa mensagem, siga os passos abaixo:

1. Acesse a rotina 560 - Atualizar Banco de Dados;

2. Na aba Criação/Alteração de Tabelas, sub-aba P, sub-item Pro, marque a opção Tabela Cotações de produtos (PCPRODUTOSCOTACOES);

3. Em seguida, clique o botão Confirmar;

mceclip0.png

4. Clique Sim ao ser exibida a mensagem abaixo;

mceclip0.png

5. Aguarde o processamento total da atualização;

6. Agora, acesse a rotina 500 - Atualizar Procedure;

7. Na aba Essenciais, sub-aba Triggers, marque a opção 37 - Triggers para gravação do histórico de informações fiscais (PCNSAID/PCNFENT/PCMOV/PCHISTEST/PCDEVCONSUM/PCESTCOM);

mceclip2.png

8. Clique Atualizar e aguarde o processamento da atualização,

9. Em seguida, acesse a rotina 1402 e realize normalmente o faturamento, conforme o link: Gerar Faturamento (rotina 1402)

 

Importante
Efetue esta atualização com os usuários deslogados do sistema e com todas as outras rotinas fechadas para que a atualização seja validada completamente.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _