Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

WINT - ORA-00907: missing right parenthesis

Ocorrência
Ao realizar uma pesquisa em relatórios customizados na rotina 800 - Relatórios e consultas personalizadas é apresentada a mensagem: ORA-00907: missing right parenthesis.

Ambiente
TOTVS Distribuição Linha Winthor - 0 - Framework -  A partir da versão 30


Causa
Esse incidente ocorre quando erros de síntaxe simples executam dentro de consultas de análise (selects), podendo ocorrer principalmente por conta de um parêntese que foi inserido à esquerda sem que haja um parêntese correspondente à direita para fechar o bloco de instruções, ou ainda por conta de informações extras que estão contidas entre os parênteses. Ou seja, todos os parênteses devem ser inseridos em pares e com as instruções coerentes.

Solução
Para resolver a mensagem ''ORA-00907: missing right parenthesis'':

1. Acesse a rotina 560 - Atualizar Banco de Dados na última versão disponível;

2. Acesse a aba Controle de Atualizações e marque a opção Reprocessar Atualização;

3) Em seguida, na aba Dicionário de dados, marque a opção Criar novo dicionário de dados;

 

Importante
Lembrando que a versão da rotina que apresenta a mensagem e a versão da rotina 560 devem ser iguais.

Exemplo:
PCINFTAB V.30.0.xx.xx
PCSIS800 v.30.0.xx.xx

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _