Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

WINT - ORA-12899: value too large for columm"PONTO"."PCNFCANITEM"."DESCRICAO" (actual: xx, maximum:80)

Ocorrência
Ao cancelar um pedido na rotina 329 é apresentada a mensagem Erro: ORA-12899: value too large for columm"PONTO"."PCNFCANITEM"."DESCRICAO" (actual: xx, maximum:80).

Ambiente
Winthor - Vendas - Aplicável a partir da versão 29

Causa
Esse incidente significa que a descrição (o nome do cliente, que é cadastrado na rotina 302, na seção 01 - Capa, no campo Cliente **) mais o Número do Pedido (rotina 329) extrapolou o limite do campo, que é de 80 caracteres.  

Solução
Para cancelar o pedido, solicite que o seu DBA identifique quantos caracteres estão acima do limite,1.

Exemplo

Caso esteja 83, o campo MAXIMUM estará em 80, o que quer dizer que foi extrapolado três (3) caracteres.

Assim, no cadastro do cliente quando for corrigido e retirado esses três (3) caracteres, o cancelamento do pedido será permitido.

 2. Após a identificação, acesse a rotina 302 e faça as devidas alterações e salve.

 

Importante
- A palavra actual nesta mensagem de erro faz referência ao tamanho da descrição.

- Na rotina 530, a permissão 9801 - Permitir cancelamento de pedidos deve estar marcada.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _