Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

WINT - ORA-12705: Cannot access NLS data files or invalid environment specified.

Ocorrência
Ao se deparar com a mensagem "ORA-12705: Cannot access NLS data files or invalid environment specified"   

Ambiente
Winthor - Menu - A partir da versão 29

Causa
Esse incidente significa que quando um comando automático alter session é executado pela Oracle no momento do login, é descoberto um ambiente NLS_LANG inválido.

Algumas possíveis erros para essa mesma causa são apresentadas abaixo:

  • ORA-12705 com o parâmetro NLS_LANG incorreta;
  • ORA-12705 incorretamente especificada ORA_NLSx;
  • ORA-12705 a partir do Oracle incorreta instalação ou configuração;
  • ORA-12705 quando utilizar caracteres especiais define;
  • ORA-12705 quando conectar com o SQL * Net;
  • ORA-12705 durante as migrações;
  • ORA-12705 quando conectar com o SQL * Plus;
  • ORA-12705 quando conectando com linguagem pré-compiladores,
  • ORA-12705 durante Export/ Import.


Solução

Quando um comando alter session com um parâmetro inválido NLS é executado e a variável de ambiente NLS_LANG contém uma linguagem ou conjunto de caracteres inválidos, é necessário verificar a escrita do comando e do parâmetro para corrigi-los.

Tente efetuar a operação novamente com os valores corretos na variável de ambiente NLS_LANG.

Para erros causados por configurações NLS_LANG inválidos, verifique se está com status desativado no nível do sistema.

Em máquinas com sistema operacional Windows, o NLS_LANG deve ser renomeado no registro do Windows e a sub-chave NLS_LANG no registro \HKEY_LOCAL_MACHINE\SOFTWARE\ORACLE também deve ser renomeada. Em máquinas com sistema operacional Linux/ UNIX, execute o comando NLS_LANG unset

 

Importante
Qualquer verificação de configurações ou operações referentes à banco de dados devem ser realizadas pelo DBA da empresa.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _