FAQs - Suporte técnico

MP - ADVPL - Invalid call to a PRIVATE data named  DESCRIPTION

Ocorrência

Descrição de erro: [Invalid call to a PRIVATE data named  DESCRIPTION__}Pilha de Erro: [
THREAD ERROR ([71864], HTTP_WT_P1225_HTTPREST_HTTPURI@99þ01|FALSE, THIS)   13/04/2020 16:06:48
Invalid call to a PRIVATE data named  DESCRIPTION__ on H_FWRESTSRV(FWRESTSRV.APH) 05/03/2020 22:36:09 line : 21

[TOTVS build: 7.00.170117A-20200102]
Called from FWAPILIST(FWRESTSRV.PRW) 05/03/2020 22:36:09 line : 544
Called from REST_CONNECT(FWRESTSRV.PRW) 05/03/2020 22:36:09 line : 437
Called from HTTP_WT(FWHTTPSRV.PRX) 05/03/2020 22:36:09 line : 883
]

Ambiente
Protheus  – ADVPL  – A partir da versão 12

Causa
Esse incidente ocorre, pois a classe WSRESTFUL não pode ser em TLPP.

Solução
Para solucionar essa ocorrência, compile a classe em  .PRW ou .PRW.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _