Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

MP - SIGALOJA - Produto não localizado ou com divergência de preço utilizando Tabela de Preço

Ocorrência
No Módulo Controle de Lojas, via rotina Venda Assistida, ou no Módulo TOTVS PDV, ao finalizar uma venda, o sistema não localiza produto ou não traz valor correspondente a tabela de preço cadastrada.

Ambiente
Microsiga Protheus – SIGALOJA/SIGAFRT/TOTVS PDV – A partir da versão 11.80

Causa
Esse incidente ocorre pois a vigência cadastrada em Tabela de Preço não corresponde a data atual ou parametrização esta incorreta.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:

1. Em sua Retaguarda acesse a rotina Tabela de Preço (Controle de Lojas>Cenário de Vendas>Tabela de Preço) selecione a regra ativa e clique em alterar;

2. Valide os campos:

  • Data Inicial (DA0_DATDE - Data de início da vigência da tabela de preços)
  • Hora Inicial (DA0_HORADE - Hora de início da vigência da tabela de preços)
  • Data Final (DA0_DATATE - Data de término da vigência da tabela de preços)
  • Hora Final (DA0_HORATE - Hora de término da vigência da tabela de preços)
  • Vigência (DA1_DATVIG - Informe a data de vigência do item da tabela de preços)

mceclip2.png

3. Parâmetros abaixo devem ser validados em ambos os ambientes:

Parâmetro Tipo Descrição Conteúdo
MV_LJCNVDA L Habilita a integracao entre os modulos SIGALOJA e regras de desconto, bonus e tabela de preços. .T.
MV_LJRETVL C Valor da tabela de Preço.1=Retorna menor preço de  uma tabela, 2=Retorna maior preço de uma tabela, 3=Retorna o preço da tabela config. no MV_TABPAD. 3
MV_TABPAD C Preco Padrao para digitacao de vendas. 001
MV_CONFCLI  C Indica se é para utilizar a configuração do cliente na venda.
(S = Utiliza) (N = Não Utiliza).  
N
MV_LJRGDES L Habilita novo modelo de regra de desconto. .T.

 

4. Tratando-se de TOTVS PDV, após ajustes crie uma nova carga das tabelas DA0 e DA1 através da Rotina Assistente de Geração de Carga:
Atualizações>Off-line>Carga>Assistente de Geração de Carga

5. Em seguida realize o recebimento da mesma em TOTVS PDV:
Atualizações>Frente de Lojas>Carga>Assistente Importação de Carga

6. Caso esteja emitindo a venda apenas via Venda Assistida, valide os parâmetros e teste rotina.

7. Ainda no TOTVS PDV, caso cenário persista, possivelmente a estrutura das tabelas DA1 e DA0 esta corrompida, siga os passos abaixo para devido ajuste: 

7a. Renomeie os arquivos DA1 e DA0 (.dtc ou .dbf) de seu PDV e exclua os arquivo .cdx correspondentes.

7b. Valide e certifique-se que o dicionário das tabelas entre PDV e Retaguarda são idênticos (SIX, SX2 e SX3).

7c. Edite o menu do TOTVS PDV  via configurador (SIGAFRT.xnu) e inclua a Rotina OMSA010.

7d. Acesse a Rotina OMSA010 através de seu PDV, desta forma, será criado a estrutura DA1 DA0 novamente.

8. Gere uma nova carga em sua retaguarda com as tabelas correspondentes, em seguida as receba no PDV e realize um novo teste.

 

 

 

Saiba Mais:

MP - SIGALOJA - Como habilitar a tabela de preço por cliente

MP - Como funciona o parâmetro MV_TABPAD

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _