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Framework - Linha Datasul - TEC - Jboss não está acessível após iniciar o serviço

time.png Tempo aproximado para leitura: 00:01:27 min

Ocorrência
Após iniciar o serviço do Jboss, não é possível o acesso ao produto, nem o Console do Jboss.
No log do Jboss, podem ser identificadas as mensagens:
jboss.cache:service=TomcatClusteringCache org.jboss.cache.CacheException: Initial state transfer failed: Channel.getState() returned false
WARN [org.jgroups.protocols.pbcast.GMS] join(10.0.0.21:55015) sent to 10.0.0.64:57143 timed out, retrying

Ambiente
Framework - Framework (Linha Datasul) - JBoss - Todas as versões

Causa
Falha de comunicação entre instancias do Jboss na mesma rede.

Solução
Alterar o endereço de Multicast do Jboss para que não seja localizada nenhuma outra instância naquele endereço. Caso existam várias instâncias na rede, cada instância deverá ser configurada com um endereço de Multicast diferente 224.0.0.0 até 239.255.255.255.

Altere o arquivo service-[9999].bat incluindo o parâmetro -u 236.155.155.155 após o -b 0.0.0.0. Exemplo:  -b 0.0.0.0 -u 236.155.155.155 

Importante
No arquivo há 2 pontos que devem ser alterados.

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