Ocorrência
Ao abrir uma rotina no Menu é apresentada a mensagem: Erro: A loja informada não é válida. Logon negado.

Ambiente
Winthor - Menu - Versão 29.
Causa
Essa mensagem ocorre quando há erro de configuração do arquivo TNS ou mudança no arquivo winthor.ini.
Solução
Para corrigir, realize os passos abaixo:
1. Solicite seu TI para localizar o arquivo TNSnames;

2. Abra o arquivo TNSnames e verifique se está configurado corretamente;
3. Confira se o [NOME_DA_CONEXAO] ou [NOME_DA_INSTANCIA_DO_BD] está diferente do que foi configurado pelo DBA:
[NOME_DA_CONEXAO] =
( DESCRIPTION =
(ADDRESS = (PROTOCOL = TCP)(HOST = [NOME_DO_SERVIDOR])
(PORT = [PORTA_CONFIGURADA_LISTENER]))
(CONNECT_DATA = (SERVICE_NAME=[NOME_DA_INSTANCIA_DO_BD] ))
)
4. Caso não saiba qual é a configuração correta, abra o arquivo TNSnames em outra máquina que esteja funcionando, compare os dois arquivos e verifique o que está diferente e realize a configuração;
3. Se o arquivo winthor.ini foi alterado, verifique com seu TI ou DBA a parametrização do arquivo TNSnames nas máquinas que apresentarem o erro.
Observação
Caso o problema não seja solucionado acione o responsável pelo banco de dados (DBA) para que ele analise a falha de comunicação com o banco.
0 Comentários